SUMMARY OF PROCEDURES FOR THE EXCEL READING LIST WORKSHOP—(For Excel
2007/2010 Users ONLY) (Rev. 2)
	***VERY IMPORTANT, PLEASE READ THIS FIRST***
· The instructions that follow apply only  to Excel 2007, and will not match what you saw on your screen if you took the (older) “Spreadsheet Creation with Excel XP/2003” workshop.  This is because there are significant differences between the Excel XP/2003 system of menus and button bars and the new Excel 2007 “ribbon.”   Since many students own computers with the new Excel 2007, this handout is intended to serve as a summary of skills they learned in the (current) “Spreadsheet Creation with Excel 2007” workshop.
· If you have access to a computer that has the older Excel XP or 2003 and prefer to have instructions that exactly match what was done in the (older) “Spreadsheet Creation with Excel XP/2003” workshop, please download the handout entitled “Summary of Procedures for the Excel Reading List Workshop—(For Excel XP/2003 Users ONLY) (Rev. 3)” which can be found at the following URL:  http://www.ilstu.edu/~bafrans/ .
· If you do not have ready access to a computer with Excel 2007, you are encouraged to visit a computer lab on campus (like the DeGarmo 308/309 Microcomputer Lab) where you should be able to find what you need.
· Before creating your reading list in Excel 2007, be sure to check with your professor to make sure he/she can open Excel 2007 files., If not, you should either (1) use the Save as option--(accessible by clicking on the large round Office Button located in the upper left corner of the Excel 2007 screen)--to save your project as an Excel 97-2003 Workbook file or (2) use Excel XP or 2003 to create your project.
· If you are new to Microsoft Office 2007, you might want to view the tutorial entitled “Up to speed with Excel 2007” at the following URL: http://office.microsoft.com/en-us/training/CR100479681033.aspx .  It explains how to use the new Excel “ribbon” which replaces the traditional menus and button bars.
· Instructions for creating a graph of information in your reading list can be found in the video clip entitled “Using Excel 2007 to Create Graphs of Information in Your Reading List” which is available at the following URL:  http://www.ilstu.edu/~bafrans/ .


Creating the Reading List
To create a reading list (database), perform the following steps:
1. Generate the header row by entering short descriptions for each field in the database.
2. Use the Font Color and Fill Color buttons in the Font group under the Home tab on the Excel ribbon to give cells in the header row a distinctive appearance.
3. Since you will be using the Form button in the following step, you will need to place it on the Quick Access Toolbar for easy access.  To do this, follow these steps:

a. Click on the Customize Quick Access Toolbar button on the right side of the Quick Access Toolbar located above the Excel ribbon at the top of your screen.  (This button has a – and a downward-pointing arrow on it.)
b. In the Excel Options window that now appears on your screen, open the Choose commands from menu and click on the Commands Not in the Ribbon option to select it.
c. In the pane on the left that contains the list of available options, scroll down to the one named Form and click on it to select it. Then, click on the Add button to add it to the pane on the right that shows all of the options available on the Quick Access Toolbar.
d. Click on the OK button at the bottom right of the Excel Options window to close the window.  You should now see the Form button near the right side of the Quick Access Toolbar.

4. Click once on the header row and then open the form tool by clicking on the Form button near the right side of the Quick Access Toolbar.
5. For each record you wish to enter, click the New button on the right side of the form tool and enter the appropriate information for each field.  (To move from field-to-field within a record, use the Tab key instead of hitting Enter.)
6. When you are done entering records, click the Close button on the right to dismiss the form tool

7. Don’t forget to save your work.

Managing “Sheets” within the Reading List

Your reading list can contain one or more pages (or “sheets”).  Each individual sheet provides you with a place where you can demonstrate a particular competency (i.e., sorting, filtering, performing calculations, creating a graph, etc.).  Each of the following bulleted items describes how to perform a particular sheet-related task:
· To create a duplicate copy of your original reading list where you can demonstrate a particular competency, right-click on the tab at the bottom of the screen (usually named “sheet 1”) that corresponds to the sheet containing your original reading list and select the Move or Copy option from the pop-up menu.  Then, in the Move or Copy window that appears on your screen, put a check in the Create a copy box, and select (by clicking) the move to end option before clicking on the OK button to close the window.  You can now navigate to the duplicate sheet you just created by clicking on the new tab that appears at the bottom of the screen.
· To change the name of a sheet to one that more accurately describes its contents (or names the competency you are trying to demonstrate), right-click on the tab at the bottom of the screen that corresponds to the sheet you want to rename and select the Rename option from the pop-up menu.  Then, type in the new name (e.g., “Original”, “Sort”, “Filter”, “Calculate”, “Graph”, etc.) and hit the Enter key.
· To move a sheet to a new location in your reading list, right-click on the tab at the bottom of the screen that corresponds to the sheet you want to move and select the Move or Copy option from the pop-up menu.  Then, in the Move or Copy window that appears on your screen, select (by clicking) the name of the location where you wish to move the sheet before clicking on the OK button to close the window.

· To delete an unwanted sheet, right-click on the tab at the bottom of the screen that corresponds to the sheet you want to delete and select the Delete option from the pop-up menu.  If the Microsoft Office Excel warning window appears, click the Delete button at the bottom to confirm that you really do want to delete the sheet and all the data it contains.
Inserting Text Boxes in the Reading List

To create a text box containing comments anywhere in the reading list (regardless of whether the sheet contains a table or a graph), perform the following steps:

1. Assuming there is more than one sheet in your reading list, navigate to the sheet where you wish to insert the text box by clicking on the appropriate tab at the bottom of the screen.
2. Click on the Text Box button in the Text group under the Insert tab on the Excel ribbon.  Your mouse cursor now takes the form of an inverted cross.
3. Position the mouse cursor at the location on the sheet where you want one of the four corners of your text box to be, and then left-click and drag your mouse to draw a box of the desired shape and size.  (To move the text box around the sheet, left-click and drag anywhere on the border of the box where there is not a small (round or square) “handle.”  To change the shape and/or size of the text box, left-click and drag on any one of the small (round or square) “handles” on the border of the box.  To change the appearance of the text box itself, or the background color of the box, click anywhere on (or in) the box and select the appropriate option from the Shape Styles group under the Format tab in the Excel ribbon.)
4. Type the text you wish to insert into the text box you just created.  You can use any of the usual text formatting buttons in the Font group under the Home tab in the Excel ribbon.to change the appearance of the text inside the text box.  (Just be sure to highlight the text with your mouse before applying these changes.) 
Extracting Useful Information from the Reading List
To search the reading list for all records containing specified information in a particular field, perform the following steps:
1. Click once on the header row, and then open the form tool by clicking on the Form button near the right side of the Quick Access Toolbar.  (If you have not already put the Form button on the Quick Access Toolbar, please follow the instructions in step 3 under the heading entitled “Creating the Reading List.”)
2. Click the Criteria button on the right and enter the information you are searching for in the appropriate field of the form tool.  Then, click on either the Find Next or Find Prev buttons to display each record that contains the information you specified.

3. To perform additional searches, repeat step 2 and be sure to erase any information from previous searches before typing in a new search string.

4. When you are done searching, click the Close button on the right to dismiss the form tool
To sort reading list records on the contents of one or more fields, do the following:
1. Click once on the header row, and then click on the Sort button in the Sort & Filter group under the Data tab on the Excel ribbon.

2. Regardless of whether you are sorting on only one field, or on multiple fields, select the (only or first) field of interest from the Sort by menu under the Column heading in the Sort window that now appears on your screen.  (Check to make sure that the My data has headers option near the top right of the Sort window is checked.)
3. Select the Value option from the menu under the Sort On heading for the current field of interest.
4. Depending on the contents of the current field of interest (i.e., text or number), do one of the following:

· If the field contains text values, select either the A to Z option—(most common) or the Z to A option from the menu under the Order heading.
· If the field contains numeric values, select either the Smallest to Largest option—(most common) or the Largest to Smallest option from the menu under the Order heading

5. If you are sorting on only one field, or have finished sorting on multiple fields, proceed to step 6.  If, on the other hand, you need to sort on additional fields, click on the Add Level option near the top left of the Sort window, select the next field of interest from the Then by menu under the Column heading, and then go back to step 3.
6. Click the OK button at the bottom of the Sort window to close the window and display the newly sorted records.

To filter out unwanted information from the reading list and display only the desired records, perform the following steps:

1. Click once on the header row, and then click on the Filter button in the Sort & Filter group under the Data tab on the Excel ribbon.  Notice that every field name in the header row now has a small downward-pointing arrow to its right indicating that filtering options are available.
2. To filter on a particular field, click on the downward-pointing arrow to the right of that field’s name in the header row.  Then, from the pull-down menu that appears, remove the check mark from the Select All check box under the Text Filters or Number Filters headings (depending on whether the field contains text or number values, respectively) and select the field content you want to display by clicking in the appropriate check box(es).  When the OK button is clicked, all records that do not contain the specified field value(s) will be “filtered out,” and only the desired records will be displayed.  Note that the field you have filtered on now has a tiny funnel next to the downward-pointing arrow to the right of its name in the header row.  (More complex filtering can be accomplished with the aid of the Custom option in the menu to the right of either the Text Filters or Number Filters headings.)  
3. If desired, the previous step can be repeated again and again to generate an even narrower subset of the original data.
4. To once again reveal the (filtered out) records, simply click on the downward-pointing arrow to the right of every field name you filtered on in steps 2 and 3 (above), and then click in the Select All check box under the Text Filters or Number Filters headings.  Be sure to remove the filters in the opposite order in which they were applied.
5. If you ever want to disable filtering and get rid of the small downward-pointing arrows, simply click again on the Filter button in the Sort & Filter group under the Data tab on the Excel ribbon.
Performing Simple Calculations within the Reading List
To perform simple calculations with formulas, follow these steps:
1. Click in the cell where you want the result of the calculation (i.e., the answer) to appear.

2. Click in the Formula Bar and type in the = (equal) sign.  (Note that the Formula Bar is the long empty field below the Excel ribbon at the top of the screen and to the right of the button with the fx characters on it.)
3. Use the mouse to select the cell(s) that contains the first numerical value(s) you wish to insert in your formula.  The address of the cell (or range of cells) will now appear to the right of the = sign in the formula bar.  (If you wish to type in a number rather than reference values in other cells, simply enter the appropriate digits in the area of the Formula Bar where the cell (or range) reference would normally appear.)
4. Click to the right of the area of the Formula Bar where you just inserted the cell address(es) (or numbers), and type in the appropriate arithmetic operator (i.e., +, -, *, /).  (Note that because Excel performs multiplication and division before addition and subtraction, you must pay close attention to the order in which you enter values and operators.  Feel free to use ( ) to achieve the desired order of operations.) 
5. Now, use the mouse to select the cell(s) that contains the next numerical value(s) you wish to insert in your formula.  The address of the cell (or range of cells) will now appear to the right of the arithmetic operator you previously typed into the Formula Bar.  (As before, if you wish to type in a number rather than reference values in other cells, simply enter the appropriate digits in the area of the Formula Bar where the cell (or range) reference would normally appear.)

6. Repeat steps 4 and 5 as many times as is necessary to produce the desired formula.

7. When you  have finished entering the formula, simply hit the Enter key to see the result of the calculation appear in the cell you selected in step 1.
8. If you wish, you may use the Copy and Paste buttons in the Clipboard group under the Home tab of the Excel ribbon to copy the contents of the cell containing your formula to other cells in the same column (or row) of your spreadsheet.  This will enable you to use the same formula with different numerical values.  Just remember that the cell references normally used in formulas are relative rather than absolute (i.e., the addresses of the cells referenced in your formula change as the formula is copied and pasted into other rows or columns in the spreadsheet, and are hence not “locked” to a particular column or row).
	***Note:  If you ever need to use absolute addressing to prevent a cell reference from changing to another column or row while copying a formula into other cells in your spreadsheet, you have the following 3 options:

· If you want to “lock down” the column reference in a formula to prevent it from changing when the formula is copied and pasted into other cells, insert a $ before the column reference in the original formula before copying and pasting (e.g., a cell reference of $C7 prevents the column reference from being altered to anything other than column C while still allowing the row reference to change).

· If you want to “lock down” the row reference in a formula to prevent it from changing when the formula is copied and pasted into other cells, insert a $ before the row reference in the original formula before copying and pasting (e.g., a cell reference of C$7 prevents the row reference from being altered to anything other than row 7 while still allowing the column reference to change).

· If you want to “lock down” both the column reference and the row reference in a formula to prevent them from changing when the formula is copied and pasted into other cells, insert a $ before both the column reference and the row reference in the original formula before copying and pasting (e.g., a cell reference of $C$7 prevents both the column reference and the row reference from being altered to anything other than column C and row 7, respectively).


	Calculating the “Average Used to Find the Reading Level:”  An Example of UsingFormulas

The formula for calculating the “average used to find the reading level” is:

=(6ltrwdsB+6ltrwdsM+6ltrwdsE)/3

where:

6ltrwdsB=the number of six-letter (or larger) words in four sentences somewhere around the beginning of the book

6ltrwdsM=the number of six-letter (or larger) words in four sentences somewhere around the middle of the book

6ltrwdsE=the number of six-letter (or larger) words in four sentences somewhere around the end of the book

(Note that this formula simply calculates the average of the above three values.  It is not the “reading level” itself.  Instead, it is the number you need to look up in the table provided to you by your instructor to find the “reading level.”)

To enter this formula into your Excel reading list for the first book, please do the following:

1. Click in the cell where you want the calculated value of the “average used to find the reading level” for the first book to appear.

2. Type the = sign into the Formula Bar followed by the ( symbol.
3. Click in the cell where the value of 6ltrwdsB for the first book appears.

4. Type the + sign in the Formula Bar to the right of the coordinates of the cell you just clicked on in step 3.

5. Click in the cell where the value of 6ltrwdsM for the first book appears.

6. Type the + sign in the Formula Bar to the right of the coordinates of the cell you just clicked on in step 5.

7. Click in the cell where the value of 6ltrwdsE for the first book appears.

8. Type the )/3 symbols in the Formula Bar to the right of the coordinates of the cell you just clicked on in step 7.

9. Finally, hit the Enter key and the calculated value of the “average used to find the reading level” for the first book will appear in the cell you clicked on in step 1.

To calculate the “average used to find the reading level” for all remaining books in your reading list, simply copy the contents of the cell where the “average used to find the reading level” for the first book appears to the Windows clipboard, and then paste the contents of the Windows clipboard into all remaining cells (below) where you want the calculated “average used to find the reading level” to appear.  To do this, please follow these steps:

1. Once again, click on the cell where the calculated value of the “average used to find the reading level” for the first book appears (see steps 1-9 above).

2. Click on the Copy button in the Clipboard group under the Home tab on the Excel ribbon to copy the contents of the cell in step 1 to the Windows clipboard.

3. Highlight all remaining cells in the reading list where you want the calculated value of the “average used to find the reading level” to appear.

4. Finally, click on the Paste button in the Clipboard group under the Home tab on the Excel ribbon to paste the formula for finding the “average used to find the reading level” into all the cells you just highlighted in step 3.

***Note:  It is always a good idea to use a calculator to "spot check" a few of these calculated values to make sure they are correct.


To assist you in performing routine calculations, Excel offers a variety of useful functions.  To take advantage of these “premade” formulas, follow these steps:

1. .Click in the cell where you want the result of the calculation (i.e., the answer) to appear.

2. Click on the Insert Function button (i.e., the button with the fx characters on it) to the left of the Formula Bar to display a list of the available functions.  Click on the function you wish to use (i.e., SUM, AVERAGE, MAX, etc.) and then click on the OK button at the bottom to close the window.

3. Excel will now display another window that shows the address of the cell (or range of cells) it thinks you want to use as arguments with the function you selected.  Verify that the addresses are correct and make any changes that are necessary before clicking on the OK button at the bottom to close the window.  The results of the calculation will now appear in the cell you selected in step 1.

4. If you wish, you may copy the contents of the cell containing your function to other cells in the same column (or row) of your spreadsheet.  This will enable you to use the same function with different numerical arguments.  Just remember that the cell references used with your function are relative rather than absolute.  (If you ever do need to use absolute addressing, please refer to the gray box at the bottom of step 8 of the instructions for performing calculations with formulas (see above).)
	Numbering Books in the Reading List:  An Example of Using Functions

Some students want to number the books in their reading list.  To do this, we can employ the built-in “ROW” function.  With the aid of this function, every row in a spreadsheet is assigned a sequential number (i.e., the first row is assigned the number 1, the second row is assigned the number 2, and so on).  (Please note that the technique described here assigns to each row a number which is incremented up by 1 from the previous row, and is not intended to serve as a mechanism for “weighting” row numbers with values other than 1 to reflect different kinds of books.)  When we realize that the first row in our spreadsheet is the header row rather than a record for a particular book, we must find a way to subtract 1 from each row number (i.e., the second row (or record for the first book) should be assigned the number 1, the third row (or record for the second book) should be assigned the number 2, and so on).  The syntax for doing this is:

=ROW()-1

Where:
ROW()=the function that displays the row number for a particular cell—Note that this should be typed in as ROW followed immediately by ( and then immediately by ) and not as ROW followed by the numeral 0.
-1=the adjustment that needs to be made to the row function in order to match the correct number with the appropriate book (record) in our database  

If you have not yet created an empty column in the reading list for the book numbers, please click anywhere in the column to the right of where you wish to insert the new (blank) column, and then click on the downward-pointing arrow to the right of the Insert button in the Cells group under the Home tab on the Excel ribbon.  In the pull-down menu that opens, click on the Insert Sheet Columns option to select it.  A new (empty) column will now appear to the left of the column you just clicked on.  Don’t forget to specify a name for this newly-created column by typing in the appropriate label in the header row (e.g., Book Number, Book #, Num, etc.).

To number the first book in the reading list, please do the following:

1. Click on the cell where you wish to insert the book number for the first book in your reading list and carefully type the following into the formula bar:
=ROW()-1

Note again that this should be typed in as =ROW followed immediately by ( and then immediately by ) and finally by -1 and not as ROW followed by the numeral 0 and then -1.

2. Then, hit the Enter key.  The number 1 should now be displayed in the cell you clicked on.

To number the remaining books in the reading list, please do the following:

1. Once again, click on the cell where the book number for the first book appears (see steps 1-2 above).
2. Click on the Copy button in the Clipboard group under the Home tab on the Excel ribbon to copy the contents of the cell in step 1 to the Windows clipboard.
3. Highlight all remaining cells in the reading list where you want the book number to appear.
4. Finally, click on the Paste button in the Clipboard group under the Home tab on the Excel ribbon to paste the formula for finding the “average used to find the reading level” into all the cells you just highlighted in step 3.
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